Need help aprilia sr 125 2t spluttering when holding throttle

Discussion in 'General Scooter Discussion' started by T33omm, Feb 18, 2019.

  1. T33omm

    T33omm New Member

    Messages:
    7
    Hi guys new to the forum, I have a Sr 125 2t and acceleration is perfect and open throttle is perfect top end is perfect, but say I hold it at 40mph,50mph or 60mph it’s starts spluttering slowly pull the throttle more it’s fine balance off and hold it at a steady speed it starts spluttering again any ideas.


    Cheers tom
     
  2. T33omm

    T33omm New Member

    Messages:
    7
    Forgot to mention it’s got a stupid cheap looking cone air filter thing and don’t know if it’s been jetted for this
     
  3. Stevep

    Stevep Well-Known Member

    Messages:
    4,894
    Thats a wierd one.......
    If acceleration and top end is fine I would rule out the air filter, that would affect the entire range.
    Maybe the air/fuel mix screw needs playing with or maybe the slide needle could do with raising one notch on the circlip (put the clip on the next slot down the pin).
     
  4. T33omm

    T33omm New Member

    Messages:
    7


    I just took my carb off and had a look at the main jet and it’s a 100 surely that’s way to big for a standard bike
     
  5. Stevep

    Stevep Well-Known Member

    Messages:
    4,894
    Not really, as an example, the vx125 has a 108 main jet as standard.
     
  6. T33omm

    T33omm New Member

    Messages:
    7
    I’ve jus
    so hopefully it’s the standard jet and the last owner just put a filter on without jetting it
     
  7. T33omm

    T33omm New Member

    Messages:
    7
    Can’t get my head around it put standard air box on won’t go past 30mph and bogging really bad, so thought take air filter out see if the filter is causeing it didn’t make a difference tried it with the air box case open still the same took the air box off completely and was running fine up to 70mph no problem so why is it like that with the air box on also this air box is off another bike off eBay I’ve never owned this bike with a standard air box on it it’s always had a come filter on it
     
  8. Stevep

    Stevep Well-Known Member

    Messages:
    4,894
    That's because the airbox is causing a restriction.
    You might well find that the cause is actually the cone air filter itself.
    Had it a few times on a Neos I did some years ago. The K&N type filter looked good but was actually blocked, changed the filter, away it went again.
    If the bike is running fine with no filter on, as in you can hold it steady at 50mph without problems where you couldn't before, then that points to the filter.
     
  9. scubabiker

    scubabiker NITROJUNKIE

    Messages:
    5,945
    Swap to a sponge filter. The metal bit at the end of the filter is upsetting the air pulses within the carb
     
  10. T33omm

    T33omm New Member

    Messages:
    7
    It runs exactly the same with the cone filter on or off stills has the splutter when holding at a speed I was trying to find the standard size main jet but can’t find any info so I had a look at a gilera sp 125 2t because they both rolling nut engines and they run a 86 main jet so my guess it’s way over jetted and it’s running rich
     
  11. MARSH

    MARSH Whooooo!

    Messages:
    2,389
    Rides:
    Piaggio Typhoon
    The std 125 typhoon on a mikuni carb uses a 82.5 main, and yes the runner 125 has a 86 main with std airboxes, a good place to start plus needle second from top !
     
  12. T33omm

    T33omm New Member

    Messages:
    7
     

Share This Page