Piaggio Zip 50 4t 2008 Speedo problem

Discussion in 'General Chat' started by ZipMne, Jan 28, 2018.

  1. ZipMne

    ZipMne New Member

    Messages:
    16
    Hello i have problem with speedometer 9 years i have this scooter and never had any problem with anything and today
    Speedo is slow reacting not working properly km/h pointer im driving maybe 10 it appears 5 or i dont know its not working properly anyone knows how to fix this
     
  2. ZipMne

    ZipMne New Member

    Messages:
    16
    Anyone
     
  3. Sam phantom

    Sam phantom Active Member

    Messages:
    725
    Just take the cable apart and give it a good WD-40 down the outer cable protector then put the speedo cable back in side
     
  4. Mark Emerson Trentham

    Mark Emerson Trentham Well Known Member. Staff Member

    Messages:
    8,063
    Rides:
    NSC110,NE50MFF,SCV.
    Get a new cable,the ones on this model are frankly shite.! -practically hand pressure fit together with a light tap to keep it together - they fall apart quite easily,mine did on my '06'.;).
     
  5. ZipMne

    ZipMne New Member

    Messages:
    16
    I will buy it but will it fix the problem the cable looks ok worked for 5 years with no problem only once i took off the cable because i needed to clean the speedo and when i connected it again it didnt work so good then i put wd40 next day worked little better but again it slow reacting and laging
     
  6. Mark Emerson Trentham

    Mark Emerson Trentham Well Known Member. Staff Member

    Messages:
    8,063
    Rides:
    NSC110,NE50MFF,SCV.
    When i took mine out of the speedo drive,the metal end cap (fastened on by x2 'dimples') came off & the inner cable was broken off about 2"'s back.
     

Share This Page