Piaggio xevo 125cc maxi scooter

Discussion in 'General Scooter Discussion' started by Tommy A, Jun 29, 2020.

  1. Tommy A

    Tommy A New Member

    Messages:
    2
    Hi All
    I hope someone can help, I have a Piaggio xevo 2012 125cc maxi scooter and the previous owner cut the wire to the temperature sensor as the head gasket was slightly blown and the temperature guage just flashes all the time now. I am waiting of a new head gasket to arrive and be fitted but i would like the temperature gauge to work again. Does anyone know where the power supply wire to the single sensor is fed from ? is it just a 12v supply from a live connection when the engine is running ?
    Thank you for and advice and help
    Regards
    Tommy
     
  2. Shunty

    Shunty Member

    Messages:
    150
    Rides:
    Baotian BT49QT-9
    If the sensor has 1 wire to it, the chance is it goes through the sensor to earth to turn the light off
    I would imagine the 12 live comes from the ignition switch
     
  3. Tommy A

    Tommy A New Member

    Messages:
    2
    Hi thankyou for the reply, it only has 1 wire to the sensor and thats it I just dont know where the sensor is fed from, it has not got a light on its a temperature gauge on the digital display that goes from cold to hot however at the moment it just continues to just flash on and off
    regards
    Tommy
     
  4. Shunty

    Shunty Member

    Messages:
    150
    Rides:
    Baotian BT49QT-9
    I expect if you can find both ends of the cut wire and join them see what happens then
     

Share This Page