Gilera Runner 50 Overheating

Discussion in 'The Workshop' started by Typhn70, Jul 16, 2023.

  1. Typhn70

    Typhn70 New Member

    Messages:
    5
    Hey,

    Bike is 2002 Gilera Runner 50

    I’ve recently did a full engine rebuild, new crank, bearings, waterpump,.. after I put everything back together I noticed that engine overheats in about 3-5 minutes. I checked everything, bled the system 3 times, checked if the pump is running, everything seems fine. All hoses are warm, including radiator and expansion tank but when I checked the water flow returning to expension tank I noticed that its circulating very poorly almost as if the pump doesn’t give out enough pressure. I need someone to tell me that has experience, I dont need basic advices, ive tried everything.
     
  2. Stevep

    Stevep Well-Known Member

    Messages:
    5,896
    "when I checked the water flow returning to expension tank I noticed that its circulating very poorly"

    I'm guessing you mean the water coming out the little tube inside the expansion tank at the top?
    If so, it's not going to be a powerful jet of water, just a steady stream.
    Also you say it overheats in 3 - 5 minutes.
    Is this going by the temp gauge needle?
    Or can you physically hear it bubbling like a kettle?
     
  3. Typhn70

    Typhn70 New Member

    Messages:
    5
    Water doesnt even come from the top hose under idle, only at rpms but even then its like spitting water out (It used to go in a nice steady steam). And yes I go by gauge needle and turned the engine off before it could heat up even more.
     

Share This Page