53 plate piaggio st125

Discussion in 'Scooter Related News' started by normskinr30, Dec 29, 2017.

  1. normskinr30

    normskinr30 New Member

    Messages:
    4
    Rides:
    piaggio skippe st125
    hey there ppl can any one help me with a problem i seem to be having at the moment with above bike. the problem is the ignition control unit dont seem to be running my indicators and i have searched every where and cant seem to find any thiing on this issue. when i got the bike i stripped it down to clean the chassis up and respray it as i always do with every bike i get. i noticed that the wiring harness ahd been cut and played with with things added that dont belong. when i looked it was a relay for the indicators that when in use it clicked i removed this and reconnected the wires to where they came from and now i have no indicators at all????? it has had my confused now some time lol any help or advice would be good thanks in advance
     
  2. Stevep

    Stevep Well-Known Member

    Messages:
    5,654
    Go back over the work you've done
    The relay needs a positive feed to it that comes live when the ignition is switched on.
     
  3. normskinr30

    normskinr30 New Member

    Messages:
    4
    Rides:
    piaggio skippe st125
    I have gone through every thing but it looks like my cdi unit is not operating as it should I have had to put a relay in for the indicators to work and am going to put the head light on a separate switch so can still use it as normal. @Stevep thanks fella much appreciated the cdi unit is not like most it is big and blue think it is a de restricted one
     
  4. MARSH

    MARSH Whooooo!

    Messages:
    2,985
    Rides:
    Piaggio Typhoon
    The cdi does'nt run the indicators, only engine running. As stevep says, take a live feed from ignition switch upto the indicator switch, using a mutimeter find live in or look at haynes manual wiring loom, fit live to switch "in" then it should work.
     
  5. normskinr30

    normskinr30 New Member

    Messages:
    4
    Rides:
    piaggio skippe st125
    On this particular bike the cdi unit does control the indicators some call it the ignition control unit and from the cdi unit there is a blue wire that runs from the indicators have a Haynes manual and have checked and checked again I did loads of investigation work on this and went through every thing it still don’t work the cdi unit is not like most cdi’s it’s about 2.5-3 inch wide and bout the same maybe a bit more longer I will upload a pic of the cdi ASAP
     

Share This Page