Recent Activity

Activity stream for all registered members at Scooter Shack Scooter Forum.

  1. Quinton liked BigHeavy's post in the thread Indicators flashing fast only when bike is running.

    From what I can see online its a sealed unit so unlikely though id wait til someone more experienced can answer

    Jun 22, 2018 at 3:09 PM
  2. BigHeavy replied to the thread Indicators flashing fast only when bike is running.

    From what I can see online its a sealed unit so unlikely though id wait til someone more experienced can answer

    Jun 22, 2018 at 3:03 PM
  3. Quinton replied to the thread Indicators flashing fast only when bike is running.

    I've had a look through my haynes manual trying to find the indicator relay and it says that the turn signal relay is integrated into...

    Jun 22, 2018 at 3:01 PM
  4. sussexlad posted a new thread.

    Fly 125 starting issues

    7 year old 125cc fly The past month it’s been activ strange First issue was when I would turn the ignition key to find no lights or...

    Forum: The Workshop

    Jun 22, 2018 at 12:27 PM
  5. Lil' Paddy replied to the thread So the new project is waiting........

    Love the colour! Nice job

    Jun 22, 2018 at 6:37 AM
  6. allspeed replied to the thread Vespa Lx 50 hates hills.

    To update on this, bike now climbs hills fine. Fitted 7 gram rollers , Nuraku white contra spring and clutch springs. I just did the...

    Jun 21, 2018 at 7:19 PM
  7. Jayyhittaa posted a new thread.

    70CC 2004 ZIP NOT RUNNING RIGHT!!!

    This build has been going on for 8 months due to time and money, it's a joke and i'm at the point of chucking it in a skip. 70cc cast...

    Forum: General Tuning

    Jun 21, 2018 at 6:06 PM
  8. BigHeavy replied to the thread the what have you done today thread.

    Just picked up another Agility for some parts that I need for mine, £150 and a half mile push home. Adding up the prices of parts that I...

    Jun 21, 2018 at 12:52 PM
  9. AndreiMadness125 replied to the thread Jonway Madness 125 re-build (hopefully).

    Thanks, still a fair bit of work to be done yet.

    Jun 20, 2018 at 11:48 AM
  10. Quinton replied to the thread Indicators flashing fast only when bike is running.

    Yeah all normal bulbs etc, no blown bulbs or fuses, just fast flashing when revved up and riding, thanks

    Jun 20, 2018 at 10:55 AM
  11. Stevep liked BigHeavy's post in the thread Shitbox Punto Project.

    First fix Fuel cap was really starting to get on my nerves. Drilled a small hole above the key hole and used a screwdriver to get it...

    35265103_1686713581382854_4613101433489719296_n.jpg Jun 19, 2018 at 11:10 PM
  12. Stevep replied to the thread Jonway Madness 125 re-build (hopefully).

    Nope, didn't see that one, good to hear though:)

    Jun 19, 2018 at 11:07 PM
  13. Stevep replied to the thread Indicators flashing fast only when bike is running.

    Clean the earth's and lives for the indicators. When you are stationary nothing is moving, when you are riding everything is moving....

    Jun 19, 2018 at 11:04 PM
  14. BigHeavy replied to the thread the what have you done today thread.

    Picked up some LED bulbs to go all round on the Kymco. The brake light has stopped working so I'll change them all while im at work...

    Jun 19, 2018 at 9:06 PM
  15. Quinton replied to the thread Indicators flashing fast only when bike is running.

    Yeah I think it is, as it is even more so when reving and riding as apposed to ticking over

    Jun 19, 2018 at 8:55 PM
Loading...