Speedfighter 3 AC Vaccum/Fuel problem

Discussion in 'The Workshop' started by Thomas Kraus, Aug 4, 2023.

  1. Thomas Kraus

    Thomas Kraus New Member


    I must admit to defeat when it comes to solving this issue myself and therefore i need to get help from elsewhere.

    Last year, me and some buddies decided to feel young and stupid again and bought our self some scooters so that we could tune them and go on a long roadtrip. So, i scouted my area and found a Speedfight 3 AC that had been sitting for a couple of years in a basement. Its 1 owner only - and fired right up when we changed fuel and plug. At this point, it was all original and untouched.

    Now, i'm from Norway and we are known to be a bit on the chubby side(we old guys), so decided to buy a 70CC cylinder and a 19mm carb a long with an aftermarket exhaust system. We are packing some stuff on these scooters and such, and i tought getting some extra HP wouldnt hurt when going uphill and such.

    Now, the cylinder is from Athena and the carb is from Vicma and i've fitted a 90 fuel nozzle?(Injector or the little screw thing inside the carb) in it. It has an "power filter" with it. The carb has wires that plugs directly into the excisting wires of the scooter, so its made to fit this model i would think.

    Now, i cannot for the love of god get the fuel from the tank and up to the carb. I bought a new vacuum pump and still no fuel. I bought a new CDI, Coil, Plug and wire and still nothing. I'm mixing oil within the fuel tank as its a tuned engine, so i plumbed the original oil pump. I'm thinking it must be the cylinder. Thats the only thing it CAN be at this point, atleast in my head. Maybe this cylinder isn't made for a Vacuum setup or something? I dont know.

    The weird thing is that the scooter doesnt even start when using start gas directly into the carb. It sometimes backfires and runs for 1 or 2 secs and then stops again. So, this makes me think it could be something with this carb, but i dont know.

    Like, i'm soooooo close to set fire to this thing.

    Any input would be nice. I'm begging.
  2. Stevep

    Stevep Well-Known Member

    Have you got the fuel hoses the wrong way round?
    Looking at the schematic, there is a flow and return plus the vac line.
    You could also check if fuel is getting to the carb by opening the float bowl drain screw and see how much comes out.
  3. Thomas Kraus

    Thomas Kraus New Member

    Thank you for the reply sir!

    No, i'm pretty sure we have the hoses the right way(there are symbols on the vaccum pump that says what goes where). I bought an universal vaccum pump, but still the same issue.

    There is practically no fuel coming to the carb what so ever.

    But here is the thing.
    It works with the original cylinder kit - and i'm thinking its because the original has 2 piston rings?
    My aftermarket 70CC cylinder kit has only 1 piston ring?

    Vaccum is generated by the cylinder. For some reason my 70CC cylinder kit does not generate enough vaccum to transfer fuel to the carb. But it works with the original cylinder.

    We have messured the size and distance of the aftermarket cylinder and everything seems fine - so im totally at a loss. Maybe i need to buy a new cylinder kit, but make sure the new piston have 2 piston rings instead of 1?
  4. Thomas Kraus

    Thomas Kraus New Member

    I'm still at a loss when it comes to this scooter. I have now tried a different cylinder kit with 2 piston rings - but still the same issue. I bought a new Stator, and still the same issue.

    The issue must be fuel and or/vaccum. I'm thinking it must be some leak somewhere inside the engine case.

    I'm inches away from just scrapping the whole crap and or selling it for parts.

Share This Page