Piaggio Typhoon 50 Bogging and cutting out after tuning

Discussion in 'Scooter Tuning' started by Joe Mangham, Feb 25, 2021.

  1. Joe Mangham

    Joe Mangham New Member

    Messages:
    2
    Rides:
    Piaggio Typhoon 50
    Recently did a few modifcations to my piaggio typhoon 50cc,
    Added a new Leo Vince TT exhaust, new rollers 4.8g, destricted variator, 6m 64 jet, new air filter and spark plug, after we did this following this blog the ped ran somewhat okay but would cut out at red lights, in heavy traffic or at junctions if i didnt keep revs on it. Then came to the point where the ped just wouldn't start, ended up spending £100+ to find out it was a ECU problem so bought a Malossi ECU for £165, now we have this installed the bike struggled to start up, you have to ease the throttle very slowly with the new ECU and once it gets to a certain RPM will just cut out dead and you have to turn the ignition on and off to start it again else the starter motor just turns over, this getting danergous on busy roads or in traffic.
    If anyone has any advice that would be great, we aren't sure where the mixture screws are located or how much to adjust it, we are guessing the petrol is running to lean, what does it sound like to you guys?
    Hopefully someone can help, thanks Joe.
     
  2. MARSH

    MARSH Whooooo!

    Messages:
    3,020
    Rides:
    Piaggio Typhoon
    Put std cdi back on and check plug colour to see how it's running.
     
  3. Joe Mangham

    Joe Mangham New Member

    Messages:
    2
    Rides:
    Piaggio Typhoon 50
    The ped wouldn't start with the standard ECU, hense the purchase of the new Malossi one which seemed to get the bike going again but still suffering the bike cutting out at low and high revs, struggling overall, have ordered 6mm jets from 65 to 69 to test which would work best with the exhaust and new ECU, spark plug seemed to be running sweet with the old ECU as i can remember checking, haven't done so for the new ECU though.
     

Share This Page