Lexmoto Echo 50 charging issue

Discussion in 'The Workshop' started by toby h, Sep 23, 2023.

  1. toby h

    toby h New Member

    I have recently put a big bore kit to make my scooter go from a 50cc to a 80cc roughly.
    Since I have upgraded the bike I have had no end of issues related to charging.

    Also when the bike starts it doesn't allow a air filter to go on it just chokes out.

    I have put in these item brand new:
    Paired ECU+ Carb
    Air Filter
    Wiring Loom

    With all these new parts on the bike it still doesn't charge for some reason and i need help

    There are only 3 wires that come out o the stator and they are a Blue/White which leads to the ECU to allow the bike to turn over and supposedly allow charging to occur. A Yellow wire and a white wire, these two wires are in a connector block and connect to the corresponding wires in the loom and they go to the Regulator. I have conducted tests. The tests are as followed:

    Volts AC out off stator disconnect from loom whilst running. The Volts AC at idle were between 15 and 20 when at full revs it reached between 50 and 60. Once reconnected to the connector block these outputs drop to between 10 and 12.

    Regulator tests confirm the regulator works. With the old wiring loom i had all the VOLTS AC go to the regulator after being reconnected and they didn't drop volts but once I checked the Volts DC out of the regulator it wasn't between 13 and 14.5 as recommended. it was only reading 12.3 which is what the battery is at when running due to the no charge issue.

    Bypassing the wiring loom to the regulator from the stator. the stator outputs are between 50 and 60 at full revs and are the exact same when inputted to the regulator, but the live return to the batter doesn't output the correct voltage.

    Bypassing the wiring loom to the battery, this was just an experiment but the cable i ran directly to the positive on the battery has 15 volts dc in confirming the R/R is functional, but once connected to the battery it dropped to the exact battery voltage and didn't even slowly climb to 13.5 volts.

    If anyone here can help please help because i am lost on what to do now

Share This Page