Gilera Runner 180 backfiring

Discussion in 'General Scooter Discussion' started by Matic1234, May 30, 2019.

  1. Matic1234

    Matic1234 Member

    Messages:
    51
    My gilera runner 180 2t keeps burning the fuse that is next to the battery. When i am at a red light for a long time it just backfires and turns off when i want to drive and then i have to change the spark plug and its ok. Also the pinasco rev limiter doesnt work so im thinkingg its a bad stator or magnet but i dont know how to check. I think the jetting is ok because i have a 85 main jet and 21mm phbg carb with runner 50cc airbox without foam.
     
  2. milo2025

    milo2025 Trip to Trumpton

    Messages:
    727
    You can quite easily check the stator with a multimeter if you have one. I got mine from ebay £7.99 Bargain.
     
    Last edited: May 30, 2019
  3. Matic1234

    Matic1234 Member

    Messages:
    51
    How? What do i have to check?
     
  4. milo2025

    milo2025 Trip to Trumpton

    Messages:
    727
    You need to check the stator, to see if that's the reason your rev limiter isn't working. I had lots of backfiring issues with my speedfight but that was for a different reason. Peoples reactions were priceless! :D
     
  5. milo2025

    milo2025 Trip to Trumpton

    Messages:
    727
    ...but in the times we live in not good really so had to get it sorted asap :oops:
     
  6. Stevep

    Stevep Well-Known Member

    Messages:
    5,762
    If it's poppin the main fuse you have a serious short issue. I'd have all the panels off and start checking meticulously before something burns out completely.
     
  7. milo2025

    milo2025 Trip to Trumpton

    Messages:
    727
    I'm with Steve on that one. If you experience a complete burnout it could spell disaster for your scoot.
     
  8. Matic1234

    Matic1234 Member

    Messages:
    51
    Its it not shorting probably because the fuse doesnt burn immediately. When the engine is off ita fine but when i turn it on the metal part in the fuse becomes darker after some time and then in just pops. I think that if it would be shorting it would probably burn the fuse when i turn on the bike.
     
  9. Matic1234

    Matic1234 Member

    Messages:
    51
    What should be the voltage on the red wire and on the green wire when the bike is running?
     
  10. Matic1234

    Matic1234 Member

    Messages:
    51
    I took off all panels today and the wires look fine
     
  11. scubabiker

    scubabiker NITROJUNKIE

    Messages:
    7,321
    Sounds like it's over charging maybe?
     
  12. Matic1234

    Matic1234 Member

    Messages:
    51
    I bought new fuses and they gave me 5a ones instead od 15a when i put 15a today it was ok. But the rev limiter still doesnt work on my bike but it worked on my friends bike.
     

Share This Page