Aprilia sr 50r

Discussion in 'Scooter Projects' started by 4strokelover, Jun 25, 2018.

  1. 4strokelover

    4strokelover Active Member

    Messages:
    375
    Rides:
    Longjia Raptor 200
    Hey shackers.
    Sorry for lack of updates of the project been abit busy with work ect.
    A few updated tho.
    I managed to make a new wireing loom for the new engine, lights, Dash ect and got it all working and the engine runs now running premix as the oil pump is fooked.
    It runs better with no choke at all so i blocked it off.
    Still waiting on,
    New rear tire.
    New speedo cable and drive as old one was digital.
    New front wheel bearings.
    Updated pics will be up asap.
     
  2. 4strokelover

    4strokelover Active Member

    Messages:
    375
    Rides:
    Longjia Raptor 200
    So finally got the front wheel bearings sorted and no wobble now. Fork seals are fixed so no need to replace them.
    Had the indicators working until i shorted the wires and popped the flasher aha. Another thing on the list now.
    Come into a problem tho (i think)
    The exhaust seems to slowly fill up with oil !
    Any suggestions/ fixes ?
    I run premix so does anyone think i used too much 2stroke oil or spark not hot enough to burn it all ect ?
    More updates and definitly more pics to come.
     

    Attached Files:

  3. scubabiker

    scubabiker NITROJUNKIE

    Messages:
    5,837
    What oil are you using?
    Running premix shouldn't block your exhaust.
     
  4. 4strokelover

    4strokelover Active Member

    Messages:
    375
    Rides:
    Longjia Raptor 200
    Im only running cheap oil made by (carlube) i think it was called until its road worthy.
    I have a few thoughts what it might be.
    1. Too much oil in the fuel (it smokes out the exhaust aswell)
    2. Wrong spark plug so not burning hot enough.
    3. Head or base Gasket gone ? No trace of coolant tho)
    I dont know how quick it fills up but i have emptied it, started the bike and let it tick over for 10 minutes then took exhaust off but nothing. Its bugging me.
     
  5. scubabiker

    scubabiker NITROJUNKIE

    Messages:
    5,837
    Use better oil.
    That's your problem
     
  6. 4strokelover

    4strokelover Active Member

    Messages:
    375
    Rides:
    Longjia Raptor 200
    Okay matey. Ill get some descent stuff and empty the tank ect and try that.
    Any suggestions on a good oil ?
     
  7. scubabiker

    scubabiker NITROJUNKIE

    Messages:
    5,837
    Castrol, motul any of the big brands.
    I like castrol best myself
     
    4strokelover likes this.
  8. 4strokelover

    4strokelover Active Member

    Messages:
    375
    Rides:
    Longjia Raptor 200
    Thank you Scuba. I do need to get some more pictures up aswell of my bike progress as it is the project section.
     

Share This Page